Уведомления

Группа в Telegram: присоединиться

#1 Фев. 5, 2019 07:48:48

ioprst
Зарегистрирован: 2018-03-25
Сообщения: 18
Репутация: +  0  -
Профиль   Отправить e-mail  

Сборка GUI проекта + cairo

Python 3.4, GUI wxPython.

Необходимо собрать проект со всеми библиотеками в одну папку, чтобы можно было его передавать на другие ПК. Мне не нужен exe файл. Создал venv, добавил туда все библиотеки. Но в проекте используется PyGI 3.24.1 AIO, данный пакет устанавливается через exe-установочник. С этим пакетом ставится cairo. Сейчас, если запускать проект из venv, вылетает исключение

 File "D:\project\designer\svg2image.py", line 4, in <module>
    import cairo
ImportError: No module named 'cairo'

Можно как-то исправить? И возможно ли как-то добавить все, что было установлено из PyGI 3.24.1 AIO в библиотеки venv, или нужно всегда (на других ПК) устанавливать PyGI 3.24.1 AIO?

Офлайн

#2 Апрель 28, 2019 16:02:19

DamMercul
Зарегистрирован: 2017-11-26
Сообщения: 261
Репутация: +  9  -
Профиль   Отправить e-mail  

Сборка GUI проекта + cairo

Модуль установи
BU-DUM-PSSSSSS



____________________________________________________

 # Life loop
while alive:
    if (fun > boredom) and money:
        pass_day(fun, boredom, money)
        continue
    else: break

Офлайн

#3 Июнь 17, 2019 16:57:01

Striver
От:
Зарегистрирован: 2006-10-26
Сообщения: 167
Репутация: +  4  -
Профиль   Отправить e-mail  

Сборка GUI проекта + cairo

Мне не нужен exe файл.
А как там всё запускаться должно? Или Питон там уже стоит?

Так то cx_Freeze или что-то подобное - вполне рабочий вариант.

Ещё можно было бы pycairo отсюда поставить, но тут только для питона 3.5 и выше…



Отредактировано Striver (Июнь 17, 2019 17:00:50)

Офлайн

#4 Июль 19, 2019 12:49:53

ioprst
Зарегистрирован: 2018-03-25
Сообщения: 18
Репутация: +  0  -
Профиль   Отправить e-mail  

Сборка GUI проекта + cairo

DamMercul
Модуль установи
BU-DUM-PSSSSSS
не решит проблему.
Нужно ставить PyGI 3.24.1 AIO на машине пользователя, либо взять нужные dll файлы из установленного PyGI 3.24.1 AIO, а затем их подключить при запуске скрипта.

Striver
Ещё можно было бы pycairo отсюда поставить, но тут только для питона 3.5 и выше…
можно и нужно, но работать без определенных dll, которые устанавливаются с PyGI 3.24.1 AIO, не будет.

Отредактировано ioprst (Июль 19, 2019 12:52:21)

Офлайн

Board footer

Модераторировать

Powered by DjangoBB

Lo-Fi Version