Уведомления

Группа в Telegram: @pythonsu

#1 Авг. 16, 2021 21:28:27

thetruone
Зарегистрирован: 2021-08-16
Сообщения: 1
Репутация: +  0  -
Профиль   Отправить e-mail  

ПАМАГИТИ! Необходимость работы с Python3.X в Windows XP 32 bit.

Доброго времени суток.

Прошу помощи в рекомендации следующего:
1. Какая версия Python 3 лучше для Win Xp?
2. Какая версия Django лучше для Win Xp и рекомендованной версии Python?
3. Какая версия PyCharm лучше для Win Xp и рекомедованных версий вышеуказанного ПО?

Заранее благодарю.

Офлайн

#2 Авг. 17, 2021 01:56:05

py.user.next
От:
Зарегистрирован: 2010-04-29
Сообщения: 7865
Репутация: +  724  -
Профиль   Отправить e-mail  

ПАМАГИТИ! Необходимость работы с Python3.X в Windows XP 32 bit.

https://www.python.org/downloads/windows/

Скачай оттуда версию 3.3.0 . У меня есть Windows XP на виртуалке и в ней стоит и работает такой. Может быть, можно и выше взять версию, но этой хватит. Главное, не 3.2.0 , в ней баги серьёзные.

И поставь Linux. Она бесплатная и там последние версии всего работают и ставятся из репозитория. Есть также программы, которых нет для Windows, и которые нужны для работы.



Отредактировано py.user.next (Авг. 17, 2021 01:56:23)

Офлайн

#3 Авг. 17, 2021 07:32:46

doza_and
От:
Зарегистрирован: 2010-08-15
Сообщения: 4029
Репутация: +  247  -
Профиль   Отправить e-mail  

ПАМАГИТИ! Необходимость работы с Python3.X в Windows XP 32 bit.

py.user.next
И поставь Linux.
Ну вопрос в том почему человеку нужен XP.
  • Если у него слабое железо то безусловно надо linux ставить. Там всегда можно ужаться. И рабртать будет в 100 раз лучше XP
  • Если это проблемы администрирования (админы не дают менять), то по опыту скажу что в такой обстановке лучше не заниматься программированием. Если админы застряли на XP тут скорее работу надо менять а не сидеть в болоте.
  • на xp стоит “уникальный софт” В этом случае “уникальному” софту оставить “уникальный” компьютер. Купить нормальную новую машину и на нее все поставить.
А особо одаренные могут могут прогать на телефоне, докупив к нему wify клавиатуру. Туда новые питоны ставятся.



Отредактировано doza_and (Авг. 17, 2021 07:34:12)

Офлайн

#4 Авг. 17, 2021 12:38:36

py.user.next
От:
Зарегистрирован: 2010-04-29
Сообщения: 7865
Репутация: +  724  -
Профиль   Отправить e-mail  

ПАМАГИТИ! Необходимость работы с Python3.X в Windows XP 32 bit.

doza_and
Если у него слабое железо то безусловно надо linux ставить.
В любом случае лучше поставить Linux. Какова бы ни была винда, она останется старой доброй старушкой виндой. Винда - это такая бабушка, которая лезет с палкой вперёд всех без очереди, расталкивая всех других бабушек и особенно молодёжь. Так что Linux, просто Linux.

doza_and
Если админы застряли на XP тут скорее работу надо менять а не сидеть в болоте.
Может, в армии сидит человек или в подобной структуре, где квадратное катают. Где-то в армии даже покер сами себе написали на макросах Excel'я, чтобы играть. Ничего другого там не было.



Офлайн

#5 Авг. 17, 2021 14:47:49

PEHDOM
Зарегистрирован: 2016-11-28
Сообщения: 2138
Репутация: +  289  -
Профиль   Отправить e-mail  

ПАМАГИТИ! Необходимость работы с Python3.X в Windows XP 32 bit.

doza_and
Ну вопрос в том почему человеку нужен XP.
Вариант , человек просто бедный студент/школьник, учится на том чтоесть в доме/школе/институте и купить новый ПК/ноут у него нет возможности,(ровно как и снести вин и поставить линух, если это не его ПК) не рассматривается?



==============================
Помещайте код в теги:
[code python][/code]
Бериегите свое и чужое время.

Отредактировано PEHDOM (Авг. 17, 2021 14:49:02)

Офлайн

#6 Авг. 19, 2021 14:10:10

Rodegast
От: Пятигорск
Зарегистрирован: 2007-12-28
Сообщения: 2500
Репутация: +  173  -
Профиль   Отправить e-mail  

ПАМАГИТИ! Необходимость работы с Python3.X в Windows XP 32 bit.

> Ну вопрос в том почему человеку нужен XP.

Ты забыл про вариант “мсье знает толк в извращениях”.



С дураками и сектантами не спорю, истину не ищу.
Ели кому-то правда не нравится, то заранее извиняюсь.

Офлайн

Board footer

Модераторировать

Powered by DjangoBB

Lo-Fi Version