Уведомления

Jabber-конференция сообщества: pythonua@conference.jabber.ru

#1 Март 31, 2007 00:17:08

Casufi
От:
Зарегистрирован: 2006-11-19
Сообщения: 38
Репутация: +  0  -
Профиль   Отправить e-mail  

Postgres и Python 2.5

Подскажите пожалуйста существуют ли модулиЮ которые позволяют работать с postgres базой средствами Python 2.5 ?

На сайте Постгри есть ссылки на http://www.pygresql.org/ и http://initd.org/pub/software/psycopg/ но они вроде работают только с Питоом 2.4

Кроме этого. Я только начинаю изучать Питон, а так как планирую его использовать для веб разработок, то хочу сразу паралельно изучить http://initd.org/pub/software/psycopg/. Подскажите пожалуйста имеет ли смысл использовать последнюю версию Питона (2.5) или лучше 2.4



Офлайн

#2 Март 31, 2007 08:36:00

slivlen
От:
Зарегистрирован: 2006-07-06
Сообщения: 764
Репутация: +  0  -
Профиль   Отправить e-mail  

Postgres и Python 2.5

Psycopg есть и под Python 2.5: http://www.stickpeople.com/projects/python/win-psycopg/index.html

Casufi
Я только начинаю изучать Питон, а так как планирую его использовать для веб разработок, то хочу сразу паралельно изучить http://initd.org/pub/software/psycopg/.
Для веб разработок лучше изучить какой-нибудь framework с orm или хотябы просто Python db api 2.0.
Casufi
Подскажите пожалуйста имеет ли смысл использовать последнюю версию Питона (2.5) или лучше 2.4
Принципиальной разницы нет, но думаю лучше сразу начать с 2.5.



Офлайн

#3 Март 31, 2007 18:21:28

Casufi
От:
Зарегистрирован: 2006-11-19
Сообщения: 38
Репутация: +  0  -
Профиль   Отправить e-mail  

Postgres и Python 2.5

slivlen
Для веб разработок лучше изучить какой-нибудь framework с orm или хотябы просто Python db api 2.0.
Casufi
Подскажите пожалуйста имеет ли смысл использовать последнюю версию Питона (2.5) или лучше 2.4
Принципиальной разницы нет, но думаю лучше сразу начать с 2.5.
Спасибо. Я пробую Pylons и Django



Офлайн

#4 Март 31, 2007 19:37:38

Pelmen
От:
Зарегистрирован: 2007-03-31
Сообщения: 44
Репутация: +  0  -
Профиль   Отправить e-mail  

Postgres и Python 2.5

slivlen
Принципиальной разницы нет, но думаю лучше сразу начать с 2.5.
пытался начать под 2.5 вернулся на 2.4 не все библиотеки есть под 2.5



Офлайн

#5 Март 31, 2007 23:45:41

slivlen
От:
Зарегистрирован: 2006-07-06
Сообщения: 764
Репутация: +  0  -
Профиль   Отправить e-mail  

Postgres и Python 2.5

Pelmen
пытался начать под 2.5 вернулся на 2.4 не все библиотеки есть под 2.5
Вполне такое возможно, но многие библиотеки уже перенесли на 2.5. Поэтому перед переходом на 2.5 надо проверить все-ли необходимые библиотеки для него есть. Хотя это уже относится к выбору версии Питона для реализации конкретной задачи, а просто для его изучения пойдет любая версия.
P.S. А с какими библиотеками у тебя были проблемы?



Офлайн

#6 Апрель 1, 2007 11:05:52

Pelmen
От:
Зарегистрирован: 2007-03-31
Сообщения: 44
Репутация: +  0  -
Профиль   Отправить e-mail  

Postgres и Python 2.5

slivlen
P.S. А с какими библиотеками у тебя были проблемы?
я сейчас конкретно не вспомню, но когда пытался поставить Trac под 2.5 с использованием mercurial то наткнулся на какие-то проблемы. Просто я не стал их решать, а запустил все под 2.4, так как это было не принципиально.
Может быть проблема с руками была, но как я уже писал выше, мне быстрее было откатиться на 2.4, чем решать эту проблему.



Офлайн

Board footer

Модераторировать

Powered by DjangoBB

Lo-Fi Version