Уведомления

Группа в Telegram: присоединиться | Jabber-конференция сообщества: pythonua@conference.jabber.ru

#1 Апрель 17, 2007 13:05:15

Unnamed
От:
Зарегистрирован: 2006-12-27
Сообщения: 47
Репутация: +  0  -
Профиль   Отправить e-mail  

Что в новой версии? 0.9.5

Что там нового добавили?



Офлайн

#2 Апрель 17, 2007 13:12:09

cleg
От:
Зарегистрирован: 2006-11-09
Сообщения: 153
Репутация: +  0  -
Профиль   Отправить e-mail  

Что в новой версии? 0.9.5

В основном поддержку i18n и юникода.
ну и кучу фиксов…

- Routes now translates utf-8 characters during both URL generation,
and URL recognition, many thanks to David Smith for numerous patches
- The Request now has an option so that all GET/POST arguments come
in as unicode, with the decoding you prefer
- i18n now uses code contributed from Aquarium by Shannon -jj Behrens
for translation fall-backs and has browser language matching code
- Optional lazy translation options contributed by David Smith
- Routes implicit defaults (action=index, id=None) can be turned off
per route with _explicit=True
- Routes memory can also be disabled by setting the mapper to
explicit=True, which will also disable the implicit defaults


Next, some backward compatibility changes:

Webhelpers:
* WARNING: paginate now takes arguments intended for the collection
object as
query_args. This could affect backwards compatibility. This fixes
a common
issue that non-keyword arguments passed into paginate get eaten by
paginate's
keyword arguments instead of being in *args to go on to the
collection.
* WARNING: Due to a typo, the Text helper highlight function no longer
highlights text with the CSS class name ‘hilight’ by default: it
now uses the
CSS class name ‘highlight’ instead. The function's ‘hilighter’
keyword
argument has also been deprecated, use ‘highlighter’ instead.

Pylons:
* WARNING: Pylons now requires the decorator module: it no longer
packages
it as pylons.decorator. Code relying on the
pylons.decorator.decorator
function will trigger a deprecation warning and should be changed
to use
decorator.decorator.
* WARNING: pylons.h was deprecated for using projects' lib.helpers
module
directly in 0.9.3. pylons.h is now formally deprecated (emits
DeprecationWarnings). Projects still accessing pylons.h must
change the
following import:
from pylons import h
to:
import MYPROJ.lib.helpers as h



Офлайн

#3 Апрель 17, 2007 15:16:06

j2a
От:
Зарегистрирован: 2006-06-29
Сообщения: 869
Репутация: +  1  -
Профиль   Отправить e-mail  

Что в новой версии? 0.9.5

Офлайн

Board footer

Модераторировать

Powered by DjangoBB

Lo-Fi Version