Уведомления

Группа в Telegram: @pythonsu

#1 Май 18, 2020 15:15:49

Dor_boof
Зарегистрирован: 2020-05-16
Сообщения: 9
Репутация: +  0  -
Профиль   Отправить e-mail  

Couldt not find a version that satysfies the requirement pytz

Приветствую. Создал эту тему в продолжении к этой http://python.su/forum/topic/38979/ т.к. это уже больше проблема чистого джанго.

Вообщем пытаюсь установить джанго на офлайн машину. У джанго есть зависимости: asgiref, pytz, sqlparse. При попытке установить пустой пишет

 Couldt not find a version that satysfies the requirement asgiref

Типо, что не хватае модулейасджиреф и т.п. С sqlparse такаяже тема. Так вот при устаноке вручную офлайн можулей asgiref и sqlparse ошибка пропадает. С pytz же не помогает абсолютно ничего. Я уже пробовал на новую версию питона, пробовал
 pip install --pre
, искал в интернете, там пишут только, что то связанное с тем, что пип не хочет устанавливать какие-то предыдущие версии, вообщем я не смог разобраться.

Ну а самое главно, если действовать по этой процедуре на других дистрибутивах - все норм, значит конкретно тут что-то тупит

P.S. Да, чуть не забыл) Linux Ubuntu 18.04

Офлайн

#2 Май 18, 2020 15:54:16

FishHook
От:
Зарегистрирован: 2011-01-08
Сообщения: 8006
Репутация: +  558  -
Профиль   Отправить e-mail  

Couldt not find a version that satysfies the requirement pytz



Офлайн

#3 Май 18, 2020 16:42:45

Dor_boof
Зарегистрирован: 2020-05-16
Сообщения: 9
Репутация: +  0  -
Профиль   Отправить e-mail  

Couldt not find a version that satysfies the requirement pytz

Не очень понял.

Я же говорю, интернета нету.
При

 sudo python3.7 -m pip install pytz-2020.1-py2.py3-none-any.whl

пишет, что питц уже стоит, к тому же он есть в
 python3.7 -m pip list
хотя удалить вот его я не могу

Ав папке с установщиком джанго
при
 python37 -m pip install .

Выдает это

Офлайн

Board footer

Модераторировать

Powered by DjangoBB

Lo-Fi Version